Unable to debug on the Server Side from my Andriod App (Struggling to make way)

Have a Andriod app that calls a php web service using KSOAP2. The Php WebService uses nuSOAP to receive requests and send response back to the app. -

After lot of struggle was finally able to install xDebug for eclipse and get it working. What I mean by that is - I select the php file and choose “Debug As” , the IDE (Eclipse) goes into Debug perspective - So far so good.

The issues what I ran into is this. From the Andriod app when a call is made to the webservice (Line 3) it does not put my php page into debug perspective for me to walk through. What am I missing? Before running the Andriod app in debug mode, I made sure that I ran the php page in debug page with a break point at the first line. Any assistance/guidance would be very much appreciated.

//this is the actual part in my andriod app that will call the webservice

HttpTransportSE client = new HttpTransportSE(webServiceURL); 
client.call(SOAP_ACTION, envelope);

The way it should work is, when client.call begins to execute, I would like the php page in debug mode in eclipse.

I can debug php with XAMPP 1.7.4/Xdebug from eclipse-php. Just enable it from php.ini.
But some case it can not call break point because at the end of address mus include xdebug session,
You can dump variable to a text file(save to disk) in that case