Testers - Pac-Match-3

Hi, all. I wanted to publish a simple match3 game as a trial run before my more fancy match3 game launches, but after this thread I have decided not to.

In lieu of publishing it to the market I really would appreciate it if I could get some eyes on it here just make sure the basics are running bug-free. The game should run on phones, tablets, and Kindle Fire.

You can download the apk here.

Getting reports of the frame rate (top of screen) on the Benchmark screen would also be of help, especially for older/slower devices.


Tried to install on my phone (Huawei U8150 IDEOS, running Android 2.2). Failed to install with [INSTALL_FAILED_INVALID_APK].

Tried to install on an emulator instead running Andriod 4.03. Installed but immediately force close on launch. Logcat:

I/ActivityManager(  887): Start proc air.air.com.rfg.apps.pacmatch3 for activity air.air.com.rfg.apps.pacmatch3/.AppEntry: pid=1329 uid=10040 gids={3003}
W/NetworkManagementSocketTagger(  887): setKernelCountSet(10040, 1) failed with errno -2
I/StartupTime1( 1329): :1348464409174
D/dalvikvm( 1329): Trying to load lib /data/data/air.air.com.rfg.apps.pacmatch3/lib/libCore.so 0xb492bd70
W/dalvikvm( 1329): No implementation found for native Lcom/adobe/air/AIRWindowSurfaceView;.nativeSurfaceCreated ()V
D/AndroidRuntime( 1329): Shutting down VM
W/dalvikvm( 1329): threadid=1: thread exiting with uncaught exception (group=0xb405a180)
E/AndroidRuntime( 1329): FATAL EXCEPTION: main
E/AndroidRuntime( 1329): java.lang.UnsatisfiedLinkError: nativeSurfaceCreated
E/AndroidRuntime( 1329):        at com.adobe.air.AIRWindowSurfaceView.nativeSurfaceCreated(Native Method)
E/AndroidRuntime( 1329):        at com.adobe.air.AIRWindowSurfaceView.surfaceCreated(AIRWindowSurfaceView.java:711)
E/AndroidRuntime( 1329):        at android.view.SurfaceView.updateWindow(SurfaceView.java:533)
E/AndroidRuntime( 1329):        at android.view.SurfaceView.access$000(SurfaceView.java:81)
E/AndroidRuntime( 1329):        at android.view.SurfaceView$3.onPreDraw(SurfaceView.java:169)
E/AndroidRuntime( 1329):        at android.view.ViewTreeObserver.dispatchOnPreDraw(ViewTreeObserver.java:590)
E/AndroidRuntime( 1329):        at android.view.ViewRootImpl.performTraversals(ViewRootImpl.java:1617)
E/AndroidRuntime( 1329):        at android.view.ViewRootImpl.handleMessage(ViewRootImpl.java:2442)
E/AndroidRuntime( 1329):        at android.os.Handler.dispatchMessage(Handler.java:99)
E/AndroidRuntime( 1329):        at android.os.Looper.loop(Looper.java:137)
E/AndroidRuntime( 1329):        at android.app.ActivityThread.main(ActivityThread.java:4424)
E/AndroidRuntime( 1329):        at java.lang.reflect.Method.invokeNative(NativeMethod)
E/AndroidRuntime( 1329):        at java.lang.reflect.Method.invoke(Method.java:511)
E/AndroidRuntime( 1329):        at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:784)
E/AndroidRuntime( 1329):        at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:551)
E/AndroidRuntime( 1329):        at dalvik.system.NativeStart.main(Native Method)
W/ActivityManager(  887):   Force finishing activity air.air.com.rfg.apps.pacmatch3/.AppEntry

Thanks for checking it out.

Just checking - was that Logcat from the device or from the emulator?

It looks like that error has been associated with Adobe AIR on Android 2.2 when disk space is low.

Logcat is from the emulator. It won’t install onto my phone at all.

It looks like Adobe AIR is not supported on your physical device. Sorry about that.

Here is the list of supported devices:

I was able to run the apk in an emulator set to Android 4.1 with armeabi-v7a (AIR also requires ARM-v7a). I’m checking out the Android 4.03 now.

I tested the default Android 4.03 emulator profile (with armeabi-v71) and the apk installed and ran. Did you use a different profile/settings?


I was using the x86 atom emulator now that I think about it. It does have a few bugs.

Hi. I’ve now published a version on GooglePlay at: http://goo.gl/8VXfs

Thanks for your help.