StartApp's new SDK/interface/everything...

Right, so as many of you StartApp users may know, there was a new SDK released very recently, which also came with a considerable interface change to the dashboard.

I happened to have an app I’m developing listed there, flagged with a red “Not Live” icon as I hadn’t published it yet. But when I published the app today and went to StartApp to flag it as Live, I can’t for the life of me figure out what do I have to do to mark the app as live, as the old radio button that allowed you to toggle Live/NotLive is completely gone. I tried adding the Google Play link to see if it would automatically realize it’s live and switch the state to either “No Installs” or “Live”, but that didn’t work. All I can think of is that perhaps it now automatically changes state whenever an SDK install is detected, but if that’s the case, I don’t see the logic in the “No Installs” icon still existing. Can someone who’s recently added StartApp clarify this?

Hi PedroSantos,

Thanks for picking up our SDK, hope you see good results!

The icon will change automatically to live (in case you have a valid URL entered in the edit app page) once the portal updates with today’s results.

So, wait till tomorrow and check out the status. If it’s still showing red, contact me ([email protected]) or our [email protected] and we’ll figure it out.


I’ve never had to press the button your referring to, or even knew there was one. Mine just switched to “live” the next day as I remember.
They update their data every 24 hours, so I would wait until tomorrow (if you uploaded it already).

It’s possible that I’m confusing with another ad network, though I was reasonably sure StartApp worked like that until very recently.

Anyway, thanks a lot for clearing it up!

Since the new changes I have added two apps that both have the warning “check package name”, they seem to be correct, while the previous apps have that field empty and don’t receive such warning. Can you tell me how to fix it, please?

same here

Yeah, been having the same problem as well. I was going to contact support about it as I’ve checked my package name everywhere and it always matches, but since it looks like everyone is having the issue, I’ll assume it’s an issue on their end. In any case, the apps seem to be registering revenue as normal, so it’s not like it seems to be a severe issue.