StartAPP SDK Doesn't work in Emulator..

Hi guys,

I’ve put startapp sdk on one of my apps and ran it on the emulator…

I get the EULA and when i hit Accept or Decline I get VM aborting in logcat and the EULA shows again…
Is it ok? I don’t have an Android device ATM and wanted to know if this will work on real devices…


What version of Android is the emulator on? StartApp only works on 2.1 and above.

Its 2.33

I also tried on ver 4 and it didn’t work on emulator…

Tried on a real device and it worked,

Do u get it to work on an emulator?

Also, does their dashboard update online? (or does it take time?)

Ah, well I’ve never tried it on the emulator. I have plenty of testing devices, so I rarely even use the emulator for anything.
I’ll try it out today and let you know :slight_smile:

Their Dashboard updates every 24 hours, as in just after midnight each day (obviously depends where you live), but it usually updates around 1 a.m for me in the U.K (GMT +0).

OK Great, Thanks.

BTW, something is kinda strange there, It said i had 35 downloads, but revenue is only 0.3$, aren’t they paying per install? isn’t it suppose to be 0.05x35?

It’s $0.05 per install from the U.S and $0.01 for anywhere outside the U.S. It’s also a fraction of those figures if the SDK is already on a user’s phone - for example they updated the app or already had an app with StartApp’s SDK.
Depending on where your downloads come from you will get between $10-$50 per 1k downloads. Those figures are worst case scenario and best case scenario.
If you want more information than that then I’d read though their terms and conditions. It’s all there :slight_smile: