play store upload not working


I am unable to upload anything like images, icon or apk to play store. Anyone else facing this issue. I am using my office laptop which has got a canada IP. Any developer from canda can verify this?

Having the same issue.
Trying to release an update, but its either doesn’t upload or never processes…

okay thanks for confirming. I am not alone. description etc. is getting saved fine for me just upload of anything doesn’t work.

Same here, at least I am not alone :slight_smile:

Me too. Can’t upload anything for last 2hours… when you will be able to upload sth - please inform all of us:)

Still not working. Mostly the upload stucks at 0% but sometimes at 100%

Maybe Google’s hard disk is full? :wink: :wink: :rolleyes:

I had the same problem earlier today. I kept trying every few minutes and it worked at the end

Last night I changed the title and description for one of my apps. A few hours later I checked the play store but the app was missing in the search results, so I typed the address in my browser and it said the requested URL was not found on this server. I panicked because that’s exactly what happens to suspended apps so I quickly changed the title/description, removed the screenshots, and unpublished the app. I was expecting to get a suspension email today but the app status still says unpublished on the dev portal. I wonder if this was related…

It still doesn’t work for me. This is now like for the last 12 hours or so.

Is it not letting u save/publish, or is the update just not showing up in the store?

I tried from my home network in India and upload works. But from office network which is from Canada, the upload gets stuck.

I can’t update the screenshots, which is currently all I want to do. However, I wanted to publish a new app later today or tomorrow. Until the image updating won’t work, I won’t be publishing anything new.

Thanks for sharing. I’m from EU and it’s stuck. :slight_smile:

same thing at 10:23 CET, unable to make any upload to Google Play console (APKs, screens)

grrr… How long it will be…?

Clicking upload button did not work for me. Dragging filename into the upload box worked…

sigh … Some dumbass @ Google without QA tests :frowning:

Nothing working for me still…

neither drag&drop or the normal method does not work for me still :frowning:

your country?