New Admob House Ads

anyone got them to work … I am not exactly a noob with that stuff, but for whatever reason, they do not get displayed at all.

can someone give a small step-by-step list which I can countercheck?

Thanks in advance

did you change legacy ID with the new ID?

also: The new AdMob does not show house ads to users that already installed the app that the house ad is promoting

I did set up a new inhouse campaign, text banner, assigned it to my app (to the new banner [all smart banner], with the new ids [i’ve made new ones]) and I’ve tried doing that with fixed impressions and also with eCPM. Both are getting neither requests nor impressions.

I checked in my apps and tried to figure how that new allocation stuff works (google docs are out of date) - the impression one should be shown in every case (but didnt) for the other one, I’ve tried a eCPM of 0.01 for some countries (maybe it’s too low). Everything is active. Will try a higher eCPM later on, but I hardly believe that this will change anything because the impression ones are not shown either.

I do have a lot of daily usage, so it would be just not possible that ALL of them have my new apps installed :slight_smile:

I just cannot get them to work somehow … in legacy admob this stuff was pretty straight forward (even when maintaining was a bit more clumsy)

try with BANNER, not SMART_BANNER I have not tried it yet, but i’m just guessing…

why should I do that? I’ve still some impressions from the old banners and the old (imported) house ad campaign was also producing no impressions at all (and they worked before)

no chance … whatever I do, no requests, no impressions.

I’ve tried fixed impression amount and allocate to EVERY ad I have (several formats, old new, everything is there) -> nothing

Tried several eCPM values for the inhouse ad (textad) allocated to my most viewed banner (smart banner, should work fine with textad) - nothing …

I am out of ideas …

did you try my idea?

I don’t need to, I still have some old version actively used where there are normal banners inside, I have all types of banners currently in usage an still get no impression of the housead whatsoever.

Of course I currently do not have any credits on my admob acc. well it complains about it, but I don’t think this is the reason for not displaying houseads …

try to contact support. maybe there is a bug…

Just an update, from what I’ve investigated by now … and I really wonder that noone else experience this :slight_smile:

google says on their help docs, that smart banners are not fully implemented yet … because I use Smart Banners, that could be a reason why no house ads are shown.

My old admobs (regular banners, no smart ones) should work BUT I never activated mediation there, so there are the old website IDs in place, which do not show mediation and because new admob house ads work over mediation, no house ads are displayed …

But actually there should be house ads displayed in all new-admob-interstitials … funny enough it is not the case … :frowning:

I have this similar same issue too. Everything seems setup correctly but no impressions are being display. After that, Google ask me to setup billing information first before can promote apps including house ads. Funny thing is that they charge my credit card (around USD1+) to activate this service. As soon as billing information setup completed, the house ads impressions start to run as normal.

I actually had already used adwords in the past, so my biling information (now linked to admob) is already entered since years. One problem is, that my entered credit card was expired, and I have no credit on my account.

The one thing I can try is enter the new credit card - here in spain, those brainsmurfs do not prolong your credit/debit card, but giving out completely new ones, new numbers and everything … quiet annoying …

lets try enter the new one … and lets just verify it AGAIN … thank u spain.

edit: after entering the new credit card, admob stops displaying the message about zero credits … … hm, lets see if it will now display any house ads…

finally yesterday were the first impressions delivered - seems that it actually was the expired credit card - it needed some days but now house ads getting displayed :slight_smile: thanks for any hints pointing me to that :slight_smile:

Admob House Ads / no impressions / solution | DEV BLOG