Mmedia 5.0 SDK

Has anyone been successful in implementing the new sdk? I can’t get it to work.

Haven’t updated my apps that use Mmedia yet, but will post back when I do.

Did you have any luck yet?

In admob mediation it seems to work without any changes necessary - the adapter must be 5.0 too though. With mopub it doesn’t. Haven’t tried running it standalone.

It’s works with mopub too, but you need to update mopub SDK to latest one.

Good to know. Mmedia got rid of the PHONE_STATE permission in this version of SDK so I’m eager to update.

I can’t make MMSDK 5.0 to work. It requires to call “MMSDK.initialize(Context)” to initiate the session and this static method always fails and outputs this error message in LogCat “05-01 12:03:21.495: E/MillennialMediaSDK(31406): Could not get a handshake. Not trusted server certificate”.

I wonder if you have the same error than me. Could you please check your LogCat and update your forum topic here?

Btw, I have sent an email to millenial support but they seem to never reply, just like admob does.

Millenial support knows almost nothing about technical things. I had different error (because moPub was expecting different version of the SDK I think it was missing some method or sth).

Hey Ikenna1-

The issue was the SSH encryption of the SDK’s handshake, which is how the SDK starts sessions with Millennial’s servers. We’ve put through a patch on the servers that stops this message from appearing. Feel free to send me a private message if you’ve have any other questions.