Google Play delays placement of new apps


I have published 2 new apps on the 3rd of August and they still are not findable in Google Play.

What the HELL is going on?

Red_Dot was probably banned for the use of Bomberman trademark.
As for your apps: I see both Tetriz Multiplayer Free and Tap Tap Laser Zap Multiplayer. I see 5 apps on your account in total.

Keep in mind that Tetris blocks are patented and EA might cause your Tetriz to be suspended for the use of them.

Magnesus, thanks for the clever reply regarding the trademarks. I am aware of those but that is not the issue here. Tap Tap Laser Zap does not have copy right issues but can’t be found on google play:

If you put it in “” it is in the results. So the reason is probably stupid Google search algorithm. I think the change that makes Google Play not find apps by the title was done recently - half a year ago maybe. The only solution - get your app more popular, it will be higher then and might be findable then.

I had exactly the same problem: App direct link worked, but not found using search on title or even searching my publisher name… I also had an empty publisher page (like the Red_dot page described). I filed a ticket with google at and 36 hours it was solved! I got this email below. However I saw the Red_dot issue is solved as well, perhaps it was a glitch on their side that is fixed now.

Thank you for contacting the Google Play developer support team.

We really appreciate your patience while we’ve investigated the product behavior you described.

We’ve recently made some changes that may have resolved the problem. If you’re still having trouble, please let us know and we’ll be happy to assist you further.

Thanks again and please let us know if we can be of further help.

Google Play Developer Support

try clearing out the cache of the google play app

Well, I am getting the feel that you may have got your application banned because I would say the red dot behind the application seems little confusing to me ! I would say for better information on this why don’t you try contacting the Google support ! I am sure they are the one who can help you out with such issues.

I had the same problem, there was a problem with Google play.
They changed something and some apps did not appear.
After sending an email to support team, they fix my issue.

Also, they have live chat during business hours during business days, so you can get your issues addressed quicker.

where is the life chat of admob?

Well, yes this is what I was trying to the tell the OP from the start if he can just try sending a mail over the google support team i am sure they can get back with some resolution.

are you sure?

See here: