Admob problem

Hi guys,

I have been having a problem with my admob account. I cannot update mty payment details or create a new app site. I have contacted admob guys, but they haven’t replied to my email. Its a week already. So, i wanted to know if any of you guys has experienced such problems.
So, my problems are as follows:
Problem #1 . I press Account tab ->Payment Details. I then enter my name and other details. Under Payment details i select paypal and enter my pay-pal login. I then press the submit button. Result: i am automatically logged out re-directed to admob home page.

Problem #2. I click on site & apps tab -> Add site/app.I select Android app, i then fill all the details required and the press submit button. Result: I am automatically logged out and re-directed to admob home page.

Problem #3. I try to modify app settings to change the refresh rate but i am again automatically logged out.

NB: I can log in to my account, View daily revenue and thats just it.

I would really appreciate any directions or help to help me solve this mystey. Mind you,i do understand that this is problem is account related problem and possibly not faced by many and the best guys to help me are the contact support guys. But as you know they treat us unprofessionally. I guess maybe some one has experienced such a strange behavior and can chip in some info.


Just tried editing app info - for me everything works correctly.

Maybe you have some problems with your cookie management? Have you tried a different browser?

It looks like, your problem occurs only, when processing forms

Thanks for your reply.
Yes, i tried it with Internet Explorer and Mozilla but i still get the same behavior. I really don’t know what to do, i cannot add a site as a result i am forced to re-use admob id for other apps in my new apps. Unfortunately, i am not getting any reply from Admob support staff and this is turning out to be frustrating.
Any other troubleshooting will be appreciated.

as far as I heard they are very slow in replying to emails …

I don’t have any more ideas … if I had the problem I would seek out the cookies, if they are sent correctly.

are you using google account or own account at admob? (i use google acc)

That is sad that they treat developers like that. I guess if this persists i will have to look elsewhere.

Yes, i am using my gmail account to log in to admob.

Thanks anyways. Really appreciate you. BTW… I like your game Robo Miner and we play it here in Russia with my friends:)

Hi Reiti,
It seems you were right. I had the problem with Internet Explorer, Chrome, Mozzilla and Opera browsers even after clearing and deleting the cache and cookies. But funny enough, everything seems to work alright when i downloaded Safari browser. Strange but finally it did work for me.

Thanks alot for your input. You indeed directed me towards finding a solution. Funny but for the time being, i have to be using Safari for adding a new app while i look for more solutions to my favorite browsers.

Hmm, that sounds like a strange bug. I have had similar issues before with various sites - particularly using SSL. Usually it turns out to be a combination of browser differences & a flaky connection at the time. A few days later everything is usually ok again in Chrome.

where to buy android app reviews now?