mobileCore setup

Hi guys,

I’ve singned up in mobileCore yesterday and tried to setup it in one of my app. Unfortunately the documentation is very poor :confused: It seems like it is not up to date, ie. it tells to use

public static void MobileCore.isInterstitialReady();

to check if interstitial is ready, which is deprecated.

In such case I’ve tried to add a listener to see when ad is ready, so I’ve taken the sample code and copy-pasted it

AdUnitEventListener adUnitListener = new AdUnitEventListener() {
    void onAdUnitEvent(AD_UNITS adUnit, EVENT_TYPE eventType) {


but it also doesn’t work - it gives following error:
Error:(218, 72) error: is not abstract and does not override abstract method onAdUnitEvent(AD_UNITS,EVENT_TYPE,AD_UNIT_TRIGGER…) in AdUnitEventListener
Error:(220, 13) error: method does not override or implement a method from a supertype

So finally I’ve just tried to load interstitial after some time since app start, just to see if it works. Unfortunately even when I had waited for a click in the button a minute or more, I saw following info in console:
I/MobileCore: mobileCore SDK: Requesting to show ad_unit_interstitial trigger BUTTON_CLICK
I/MobileCore: mobileCore SDK: Failed to show ad_unit_interstitial trigger BUTTON_CLICK
I/MobileCore: mobileCore SDK: Failed to show ad_unit_interstitial trigger BUTTON_CLICK | Ad unit is not ready

Just to add, I’ve added my app to mobileCore dashboard, but I don’t know if anything else needs to be done there. Should I add an add unit, if I want to use mobileCore SDK directly (without MoPub mediation)?
I’ve double checked the initial setup in gradle file and manifest but all looks fine. I need to mention that documentation presents the setup in Eclipse only, which means that is very old (no note about Android Studio).

Could you point me what is wrong here? Or could you share your examples of using this library in your apps?


Hi All,

I was reached by mobileCore team today with the solution. They wrote following:
“We have found an issue with the current SDK build that was hosted on the mobileCore website and fixed it ASAP. Please replace the current mobilecore_V1.1.jar you were using with the latest one.”

It appeared to be true, after todays download all sample code works fine now.

Thanks a lot !!! Topic closed :slight_smile:

I heard now they release Sdk v2.0. Are you using v2.0?

No, it’s still 1.1, but updated yesterday.

Edit: I’ve just logged in and saw the ad of v2.0 - I’ll try it in next days.