admob not recieving ad request

hello friends,
i have developed an application after a long time and i was integrating an admob ad into it, i found that now we have to use google play services lib to use admob ads in app.I have set up the ‘google play services lib’ in my project and doing everything as stated on developers.google.com but still ads are not showing up…

here is my code

XML


<?xml version="1.0" encoding="utf-8"?>


<LinearLayout xmlns:android="http://schemas.android.com/apk/res/android"
              xmlns:ads="http://schemas.android.com/apk/res-auto"
              android:orientation="vertical"
              android:layout_width="match_parent"
              android:layout_height="match_parent">
  <com.google.android.gms.ads.AdView android:id="@+id/adView"
                         android:layout_width="wrap_content"
                         android:layout_height="wrap_content"
                         ads:adUnitId=" a153207********"
                         ads:adSize="BANNER"
                         />
  <WebView  
    
    android:id="@+id/webView1"
    android:layout_width="fill_parent"
    android:layout_height="fill_parent"
/>
      
</LinearLayout>

and i am using these lines in java code to show the ad

AdView adView = (AdView)this.findViewById(R.id.adView);
		AdRequest adRequest = new AdRequest.Builder()
		    .addTestDevice(AdRequest.DEVICE_ID_EMULATOR)
		    .addTestDevice("TEST_DEVICE_ID")
		    .build();
		adView.loadAd(adRequest);

but still no ads are being shown…in my admob dashboard also it is showing that “red button” i.e it has not received any ad request.
what to do?..pls help…
thanks…